Login | Register
My pages Projects Community openCollabNet

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Catacomb] Re: A patch for cadaver-dasl



Actually, please change the copyright message to be Copyright (C) 2002
Regents of the University of California.

I have some legal disclaimer-like language, which I'll get to you soon.

- Jim

> -----Original Message-----
> From: catacomb-admin@webdav.org [mailto:catacomb-admin@webdav.org]On
> Behalf Of Sung Kim
> Sent: Friday, August 30, 2002 7:39 PM
> To: Joe Orton
> Cc: catacomb@webdav.org
> Subject: Re: [Catacomb] Re: A patch for cadaver-dasl
>
>
> Hello,
>
> I appreciate your comments and attach a new patch for you.
>
> On Fri, 30 Aug 2002, Joe Orton wrote:
>
> > > +++ search.c	Mon Aug 26 20:23:05 2002
> > > @@ -0,0 +1,1423 @@
> > > +/*
> > > +   'search' for cadaver
> > > +   Copyright (C) 2000-2001, Joe Orton <joe@manyfish.co.uk>,
> >
> > I'm still not really happy about this, since I didn't write the code.
> > Without a formal copyright assignment I'd prefer you owned the copyright
> > (or UCSC, or whatever).
>
> Changed it to Grase Lab, UCSC.
>
> > > +typedef struct dead_prop_t {
> >
> > POSIX owns the "*_t" namespace, I'd prefer to not invade that... you
> > probably don't need the tag name for this typedef anyway, so can you
> > just drop the "dead_prop_t" out of this declaration, and similarly with
> > resource_t.
>
> Done.
>
> > Declaring a "resource" or a "struct resource_t" is also confusing, since
> > cadaver.h already defines a "struct resource", I'm not sure what can be
> > done about that though.
>
> Changed it to search_res.
>
> > > +    case ELEM_href : /* href */
> > > +	if(sctx->curr==NULL)
> > > +	    set_xml_error(sctx, "XML : </%s> is in the wrong
> place", elm->name);
> > ...
> > > +	if(sctx->curr==NULL)
> > > +	    set_xml_error(sctx, "XML : </%s> is in the wrong
> place", elm->name);
> > ...
> > > +	if(sctx->curr==NULL)
> > > +	    set_xml_error(sctx, "XML : </%s> is in the wrong
> place", elm->name);
> >
> > Way too much duplicated code in there!
>
> Added a new MACRO and replaced them to the macro.
>
> > This is equivalent to ne_accept_207 from ne_207.h.
>
> Done.
>
> Again, I appreciate your help.
>
> --
> Sung Kim
>
>