Login | Register
My pages Projects Community openCollabNet

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Catacomb] strange error/dependency problem



looks like you've build catacomb as a static apache module, not a dso. when you start up your apache server, does the error log report something like this:

[Wed Aug 17 18:08:19 2005] [notice] Apache/2.0.54 (Unix) DAV/2 Catacomb/0.9.0 configured -- resuming normal operations

?

If so, then catacomb is properly installed.
If not, then catacomb is not properly installed.

I haven't seen the error message you mention, but I'd guess that you have built catacomb as a static/built-in module. LoadModule is for dynamic modules. To build apache so that it can LoadModules properly, you'll need to run these commands in your apache source tree:
   % ./configure --enable-dav=shared --enable-so=shared
   % make
   % make install
Then to build Catacomb as a shared module, run:
% ./configure --with-apache=/path/to/apache/server/root --with-mysql=/path/to/mysql/root
   % make
   % make install

That should install Catacomb as a shared module (likely in something like $APACHE2-ROOT/modules/libmod_dav_repos.so - where $APACHE2-ROOT is the same as /path/to/apache/server/root above)

dave

decoutsy wrote:

thanks it looks better now ! but i've still got a little problem, as i have
"Syntax error on line 232 of /usr/local/apache2/conf/httpd.conf:
module dav_repos_module is built-in and can't be loaded"
i'm not sure i really understand the meaning of this. i've deleted this line and
now httpd can be started, but i'm not so sure this was the right thing to do...
?



Quoting Joachim Feise <jfeise@ics.uci.edu>:
Yes. You don't have mod_dav enabled. Add --enable-dav --enable-dav-fs to
your Apache ./configure line.

-Joe


_______________________________________________
Catacomb mailing list
Catacomb@webdav.org
http://mailman.webdav.org/mailman/listinfo/catacomb